M1 Macはやっぱり速い!

イメージ
 M1 Mac Book Pro ネイティブ対応が嬉しい 入手して4ヶ月が過ぎ、その間に徐々にでは有るけれど、M1対応のソフトが増えてきている。 日頃使用しているブラウザはVivaldiなんだけど、これがx86→M1に対応した。 まぁ、少しは早くなるだろうと思い、更新したらサクサク感に少々驚く。 これは、ちゃんと比較しておこうとベンチマークしてみた。 最初の状況がこれ。 こいつでの測定結果。約93って感じ でもって更新後 なんと、185までアップ。arm版になるだけで、こんなに違うのか…。 ちなみに、Ryzen5 のLinux機では、133程度なので、メインマシンより速いじゃん! その割に、発熱も少なくてバッテリーの持ちがすごく良いので、これは良機の予感。 しょぼいマシン買うくらいなら、お勧めですわ。

起動時のBEEP音には意味があるんだよ

電源投入時に起動せずBEEP音が鳴る

保守をしている法人より、電話があった。
「昨日まで、動作していたDesktopPCが、今朝電源を入れようとしたら、画面は真っ暗なまま。電源ボタンが通常はグリーンなのにオレンジで点滅。おまけにBEEP音が鳴って、どうしていいかわからない」とな。

はいはい。よくある話です。寒かったからボタン電池が逝ってしまってBIOSが初期化されてしまったか?
もしくはビデオカードが逝ってしまったか…。
これまで遭遇したのは、この手のものが多かったので、現地に行って確認しますと返事をして対応。

さて、実際は…

現地入りして、電源投入。あれ?普通に起動する。
再現性のないパターンだ!マーフィーの法則だなどと心の中で笑いながら、もう少し調べることに。
キーボードが反応しない。
マウスもだめだ…。あれれ?マザーが逝ってしまったか?

と思いつつも強制電源断。

再度電源投入。

ビービー…ビービー…と断続的なBEEP音を吐いて、電話の症状を再現。
そうか、2度BEEPして間が空いて…。

マシンはDellの古めのDesktopにWindows7で、そこそこ動いていたマシンだ。
この時点でBIOS画面すら表示しないしOSの問題ではない。

ハードウェアトラブルは間違いない。

確か、Dellのマシンは起動時に異常があるとBEEP音の断続的な鳴り方で、異常個所を示していたはず。
ということで、調べてみると…。ビンゴ!
DellのSupportページに「トラブルシューティング」がありました。



コード(短いビープ音の繰り返し回数)

説明

推奨される処置
1BIOS チェックサム障害。システム基板に障害が発生している可能性があります。デルにお問い合わせください(デルへのお問い合わせを参照)。
2メモリモジュールが検出されません。
  • 2 つ以上のメモリモジュールが取り付けられている場合はモジュールを取り外し(メモリモジュールの交換または追加を参照)、1 つのモジュールを取り付けなおしてコンピュータを再起動します。コンピュータが正常に起動する場合は、障害のあるモジュールを確認するか、またはエラーが発生しないまま全てのモジュールを取り付けなおすまで、残りのメモリモジュールを 1 枚ずつ追加していきます。
  • 同じ種類で動作確認済みのメモリがある場合は、そのメモリをコンピュータに取り付けます(メモリモジュールの交換または追加を参照)。
  • 問題が解決しない場合は、デルにお問い合わせください( デルへのお問い合わせを参照)。
3システム基板に障害が発生している可能性があります。デルにお問い合わせください(デルへのお問い合わせを参照)。
4RAM 書き込み / 読み取り障害。
  • メモリモジュール / メモリコネクタの配置に特別な設置要件がないことを確認します(メモリモジュールの交換または追加を参照)。
  • 使用するメモリがお使いのコンピュータでサポートされていることを確認します。
  • 問題が解決しない場合は、デルにお問い合わせください( デルへのお問い合わせを参照)。
5リアルタイムクロック障害。バッテリーまたはシステム基板に障害が発生している可能性があります。
6ビデオ BIOS テスト障害。デルにお問い合わせください(デルへのお問い合わせを参照)。


2回なるのはメモリ異常ですな~。交換は最後の手段ということで…。

分解と掃除を実施

筐体を開けて、中を見ると埃がひどくて…。
まぁ、ついでに掃除しておくか。

と、掃除機を借りて、ずずずっと埃などを吸い込みます。

問題のメモリは1GB×2で全てのスロットがふさがっています。
抜いて確認すると、端子部分が汚れております。

フキフキして、スロットを入れ替えて完了。
開けたまま電源を入れて確認すると、異常なしで無事起動。キーボードもマウスもOK。
ネットワークも接続できる。

蓋を閉じて終了。

強制的に電源断しているのでCHKDSKをかけることにする。
案の定、いくつかのファイルが破損している。
まぁ、320GBのHDDだったので、2時間ほどかけてCHKDSK終了。
全部修復して、作業完了なり。

しかし、メモリの異常なんて久しぶりに遭遇しましたわ。
しかも突然エラーになるなんて…。BEEP音がエラー箇所を示していることを忘れていたら、泥沼な作業になるところだったよ。

使用環境が悪いせいなのか、急に寒くなって多少熱収縮して端子の汚れが影響したのか分かりませんが、まあ、無事に復旧ということです。

壊れたと言って、新しいマシンにリプレイスする方が、利益は出るんだけど、そこは悪徳業者じゃないので、ぐっと我慢して…www

また同様な症状が出る場合には、置き換えましょうね~と状況説明しておきましたけどね…。





今度は「電源ボタンのLED点滅」という事象が発生したので、まとめておいた(2018-01-30追記)

コメント

  1. 今朝電源投入事にビープ音2回ずつ鳴って起動してきませんでした。こちらの記事と全く同じ事象のようです。中開けてメモリ抜き差ししてみます。参考になりました。ありがとうございます。

    返信削除

コメントを投稿

励みになりますので、簡単で良いので一言くださいませ。

このブログの人気の投稿

VirtualBoxでUSBから起動

MEGAにも弱点があった?

Ubuntuで動作するBluetoothアダプタ